Mejora #815

instalar paquetes de marble si se detecta el dispositivo

Añadido por Fernando Toledo hace más de 3 años. Actualizado hace más de 3 años.

Estado:NuevoFecha de inicio:13-08-2015
Prioridad:NormalFecha fin:
Asignado a:-% Realizado:

0%

Categoría:Instalación
Versión prevista:Huayra 3.2
Visto en:3.0

Descripción

investigar si desde el debian-installer se puede instalar condicionalmente un paquete
por ejemplo detectar que la net es una marblepoint e instalar huayra-marble

tambien deetecta si el touch tiene firmarware 3

[ 2.528608] psmouse serio4: elantech: assuming hardware version 3 (with firmware version 0x354f01)

instalar elantech-marble-dkms

porque si tiene firmware 4 no es necesario.

[ 9.906882] psmouse serio4: elantech: assuming hardware version 3 (with firmware version 0x450f02)

Histórico

#1 Actualizado por Fernando Toledo hace más de 3 años

Se puede usar preseedlate_command y poner ahi un script que via dmidecode o alguna herramienta mas, detecte si es una marblepoint y en todo caso usar apt-install o in-target para agregar el paquete de huayra-marble

lo mismo se puede hacer para agregar el de elantech

#2 Actualizado por Fernando Toledo hace más de 3 años

encontré hooks de debian installer donde se pueden ejecutar tareas:

http://d-i.alioth.debian.org/doc/internals/apb.html

El problema que tengo aún es que el kernel del d-i no reporta el mouse como elantech ya que tiene un kernel basico.

#3 Actualizado por Fernando Toledo hace más de 3 años

Buscar una forma segura de detectar el modelo de net ya que via dmidecode no es 100% seguro

#4 Actualizado por Fernando Toledo hace más de 3 años

  • Categoría establecido a Instalación

#5 Actualizado por Fernando Toledo hace más de 3 años

  • Versión prevista cambiado Huayra 3.1 por Huayra 4.0

#6 Actualizado por Fernando Toledo hace más de 3 años

  • Versión prevista cambiado Huayra 4.0 por Huayra 3.2

Exportar a: Atom PDF